Heads Up: issue with Firmware 3.1 - Hold Z Axis

3D printers, custom projects and parts for enhancing your robot or creating one from scratch.
1 postPage 1 of 1
1 postPage 1 of 1

Heads Up: issue with Firmware 3.1 - Hold Z Axis

Post by PedroR » Fri Jan 06, 2012 5:31 pm

Post by PedroR
Fri Jan 06, 2012 5:31 pm

Hi all

We wanted to share our experience with our users with regards to a new feature (and bug) in the latest Makerbot Thing o Matic firmware (version 3.1):

Background:
Version 3 firmware introduced a new configuration option called "Hold Z axis".
What this option does - theoretically - is turn off the Z axis stepper motor when the Z platform is not moving. This reduces heating on the Z stepper and saves power.

However when the Z stepper is off, there is no torque on the Z axis and it sometimes slides down, especially if using MK6s which are heavier.
This "sliding down" causes the layers to clash onto each other and ultimately deformed prints, so this feature should always be set ON so that the Z stepper is always holding the platform.

The bug we have found is that this feature does not work as advertised (has a bug in the way t's set up) and thus results in failed or poor quality prints especially if you have an MK6.

There are 2 workarounds for this situation:
- Revert to firmware V3.0 (which introduced this option but does NOT respect it). With 3.0 the Z stepper is always on holding platform like in previous 2.x firmwares regardless of how you set the "Hold Z axis" option.

- If you're using 3.1, here is the explanation from Makerbot for a work around:

Part of that is a know issue, that 'Hold Z' flag was not working at
all in firmware pre 3.1, and when it was activated in 3.1 it was/is
inverted. If they go into MotherBoard Onboard Preferences, they
un-check hold Z (which for Firmware 3.1 only, actually enables it,
due to that bug) that should re-enable hold-z on the bot AFAIK (not
heavily tested, but basic testing is done)

That problem will be fixed in 3.2, which will be shipped on soon-ish (mid Feb?)



If you have an Mk7 you'll barely notice this because it's a lighter set but if you have an MK6 this is important information.
This bug (if you're not aware about how to fix it) may render the printer useless as prints come out with really poor quality.

Our (RoboSavvy's) recommendation is to stick with firmware V3.0 until 3.2 comes out.

Regards
Pedro.
Hi all

We wanted to share our experience with our users with regards to a new feature (and bug) in the latest Makerbot Thing o Matic firmware (version 3.1):

Background:
Version 3 firmware introduced a new configuration option called "Hold Z axis".
What this option does - theoretically - is turn off the Z axis stepper motor when the Z platform is not moving. This reduces heating on the Z stepper and saves power.

However when the Z stepper is off, there is no torque on the Z axis and it sometimes slides down, especially if using MK6s which are heavier.
This "sliding down" causes the layers to clash onto each other and ultimately deformed prints, so this feature should always be set ON so that the Z stepper is always holding the platform.

The bug we have found is that this feature does not work as advertised (has a bug in the way t's set up) and thus results in failed or poor quality prints especially if you have an MK6.

There are 2 workarounds for this situation:
- Revert to firmware V3.0 (which introduced this option but does NOT respect it). With 3.0 the Z stepper is always on holding platform like in previous 2.x firmwares regardless of how you set the "Hold Z axis" option.

- If you're using 3.1, here is the explanation from Makerbot for a work around:

Part of that is a know issue, that 'Hold Z' flag was not working at
all in firmware pre 3.1, and when it was activated in 3.1 it was/is
inverted. If they go into MotherBoard Onboard Preferences, they
un-check hold Z (which for Firmware 3.1 only, actually enables it,
due to that bug) that should re-enable hold-z on the bot AFAIK (not
heavily tested, but basic testing is done)

That problem will be fixed in 3.2, which will be shipped on soon-ish (mid Feb?)



If you have an Mk7 you'll barely notice this because it's a lighter set but if you have an MK6 this is important information.
This bug (if you're not aware about how to fix it) may render the printer useless as prints come out with really poor quality.

Our (RoboSavvy's) recommendation is to stick with firmware V3.0 until 3.2 comes out.

Regards
Pedro.
PedroR offline
Savvy Roboteer
Savvy Roboteer
Posts: 1199
Joined: Mon Jun 16, 2008 11:07 pm

1 postPage 1 of 1
1 postPage 1 of 1
cron