Bioloid Vision Module

Created by Prof. Hamid Moballegh of The Robocup Humanoid Team of Freie Universität Berlin - fumanoids.de
261 postsPage 13 of 181 ... 10, 11, 12, 13, 14, 15, 16 ... 18
261 postsPage 13 of 181 ... 10, 11, 12, 13, 14, 15, 16 ... 18

Post by hamid_m » Mon Jul 05, 2010 9:47 am

Post by hamid_m
Mon Jul 05, 2010 9:47 am

Hi everybody,

I just uploaded a new version of calibration program, which supports all versions of HaViMo for USB2Dynamixel.

Download from:
http://robosavvy.com/Builders/hamid_m/HaViMoUSB.zip

Don't forget to connect power to the module when calibrating using USB2Dyn.

In addition, I would like to make the calibration program open source. I'd be happy if anyone likes to contribute.


Best regards,
Hamid.
Hi everybody,

I just uploaded a new version of calibration program, which supports all versions of HaViMo for USB2Dynamixel.

Download from:
http://robosavvy.com/Builders/hamid_m/HaViMoUSB.zip

Don't forget to connect power to the module when calibrating using USB2Dyn.

In addition, I would like to make the calibration program open source. I'd be happy if anyone likes to contribute.


Best regards,
Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

Post by bluecat » Mon Jul 05, 2010 11:37 am

Post by bluecat
Mon Jul 05, 2010 11:37 am

hamid, thank you very much for the new software!

when you say power the board, can i connect a regular wire to the cm510 and then strip its cords , connect the left and the right to the left and the right on the havimo board and the middle to the usb2dynamixel?

i probably didn't make much sense, if you have a good solution for me i would be most gratefull =)
hamid, thank you very much for the new software!

when you say power the board, can i connect a regular wire to the cm510 and then strip its cords , connect the left and the right to the left and the right on the havimo board and the middle to the usb2dynamixel?

i probably didn't make much sense, if you have a good solution for me i would be most gratefull =)
bluecat offline
Robot Builder
Robot Builder
Posts: 24
Joined: Wed Jun 16, 2010 5:45 pm

Post by hamid_m » Mon Jul 05, 2010 12:34 pm

Post by hamid_m
Mon Jul 05, 2010 12:34 pm

Hi bluecat,

I suggest the following for connecting power to HaViMo:

http://robosavvy.com/store/product_info ... cts_id/505

best regards,
Hamid.
Hi bluecat,

I suggest the following for connecting power to HaViMo:

http://robosavvy.com/store/product_info ... cts_id/505

best regards,
Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

Post by bluecat » Mon Jul 05, 2010 4:09 pm

Post by bluecat
Mon Jul 05, 2010 4:09 pm

hi hamid,

thank you for your suggestion,
untill i get one of those, can i take the vdd and the ground pins from the havimo and connect them to the cm-510 while it is powered on, and then connect the data pin from the havimo to the usb2dynx ?
hi hamid,

thank you for your suggestion,
untill i get one of those, can i take the vdd and the ground pins from the havimo and connect them to the cm-510 while it is powered on, and then connect the data pin from the havimo to the usb2dynx ?
bluecat offline
Robot Builder
Robot Builder
Posts: 24
Joined: Wed Jun 16, 2010 5:45 pm

Post by hamid_m » Mon Jul 05, 2010 5:34 pm

Post by hamid_m
Mon Jul 05, 2010 5:34 pm

Hi,

it is possible, but dangerous ;)

Hamid.
Hi,

it is possible, but dangerous ;)

Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

Post by bluecat » Tue Jul 06, 2010 2:14 pm

Post by bluecat
Tue Jul 06, 2010 2:14 pm

Hi hamid,

i connected the vdd and the gnd (after wraping them sepratly so they wouldn't touch) from the cm-510 to the havimo and the data to the usb2dyn,

but i couldn't connect to the camera in calibration, (i switched to ttl on the usb2dyn) and i tryed all the programs from the zip file, bydway on one of the programs theres a button "open com" without a place to insert the com number and nothing happens if you press it so with that calibration software i couldn't get even the com to open.

any suggestions ?
i think theres no problem with the power the way i connected it,
the module gets a little warm.

i ordered the power adapter you suggested, it should arive next week.

thank you for all your help, oran.
Hi hamid,

i connected the vdd and the gnd (after wraping them sepratly so they wouldn't touch) from the cm-510 to the havimo and the data to the usb2dyn,

but i couldn't connect to the camera in calibration, (i switched to ttl on the usb2dyn) and i tryed all the programs from the zip file, bydway on one of the programs theres a button "open com" without a place to insert the com number and nothing happens if you press it so with that calibration software i couldn't get even the com to open.

any suggestions ?
i think theres no problem with the power the way i connected it,
the module gets a little warm.

i ordered the power adapter you suggested, it should arive next week.

thank you for all your help, oran.
bluecat offline
Robot Builder
Robot Builder
Posts: 24
Joined: Wed Jun 16, 2010 5:45 pm

Post by hamid_m » Tue Jul 06, 2010 2:43 pm

Post by hamid_m
Tue Jul 06, 2010 2:43 pm

Hi,

try uploading a photo of your platform. I may find something.

Best regards,
Hamid.
Hi,

try uploading a photo of your platform. I may find something.

Best regards,
Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

Post by JULIEN » Wed Jul 07, 2010 4:34 pm

Post by JULIEN
Wed Jul 07, 2010 4:34 pm

Hi everybody !

I tried to use the program provided by hamid and .. it works perfectly !
Thank you to Hamid for his help ! :)
Our robot can track a red ball after the calibration phase

Image

Now I search a library in C to call a motion editor page in the program
do you know where I can find it ?

I found a topic about that http://robosavvy.com/forum/viewtopic.php?t=3215&start=0&postdays=0&postorder=asc&highlight=

but for the moment I haven't found the good function..


Julien
Hi everybody !

I tried to use the program provided by hamid and .. it works perfectly !
Thank you to Hamid for his help ! :)
Our robot can track a red ball after the calibration phase

Image

Now I search a library in C to call a motion editor page in the program
do you know where I can find it ?

I found a topic about that http://robosavvy.com/forum/viewtopic.php?t=3215&start=0&postdays=0&postorder=asc&highlight=

but for the moment I haven't found the good function..


Julien
JULIEN offline
Newbie
Newbie
Posts: 2
Joined: Mon Jun 28, 2010 6:09 pm

Post by bluecat » Fri Jul 09, 2010 2:13 pm

Post by bluecat
Fri Jul 09, 2010 2:13 pm

hi hamid,

bad news for me i guess, i wanted to check if i can see the havimo in the roboplus manager at id 100, like i did the first time i connected it to the cm-510 with the normal cable, so i connected the havimo 2 and now i can't see it, i feel there is current in the module , its warm, not to hot though , and nothing seems to be damaged, did i destroy the module ?

i didn't update with pictures because i don't have enough time to mess around with it yet, ill upload some next week, but to my untrained eye there was no change in the physical condition of the module, nothing is fryed from the outside :)
hi hamid,

bad news for me i guess, i wanted to check if i can see the havimo in the roboplus manager at id 100, like i did the first time i connected it to the cm-510 with the normal cable, so i connected the havimo 2 and now i can't see it, i feel there is current in the module , its warm, not to hot though , and nothing seems to be damaged, did i destroy the module ?

i didn't update with pictures because i don't have enough time to mess around with it yet, ill upload some next week, but to my untrained eye there was no change in the physical condition of the module, nothing is fryed from the outside :)
bluecat offline
Robot Builder
Robot Builder
Posts: 24
Joined: Wed Jun 16, 2010 5:45 pm

Post by hamid_m » Fri Jul 09, 2010 2:39 pm

Post by hamid_m
Fri Jul 09, 2010 2:39 pm

Hi bluecat,

It is hard to say, did it work in roboplus manager before? if yes, then there should be a problem. I have not yet connected the module to a CM510 and never used RoboPlus manager to check if it works. try the configuration with USB2Dynamixel and external power. this is a sure way to check the module.

Best regards,
Hamid.
Hi bluecat,

It is hard to say, did it work in roboplus manager before? if yes, then there should be a problem. I have not yet connected the module to a CM510 and never used RoboPlus manager to check if it works. try the configuration with USB2Dynamixel and external power. this is a sure way to check the module.

Best regards,
Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

Question about the Havimo 2 camera???

Post by thanos79 » Tue Jul 13, 2010 2:36 pm

Post by thanos79
Tue Jul 13, 2010 2:36 pm

Hi hamid.

I have in my possession the Havimo2 camera and i try to connect to cm510 controller but i can't.
I wan't a few information...

First i connect the camera to cm510 and then connect the robot to roboplus manager and find the camera and the servos AX-12+ in roboplus manager.

Then i try to connect the camera with the USB2Dynamixel :
I connect the camera to TTL Possition and the switch to TTL
Then i go to Roboplus Terminal , Files- Tramsmit file -i find the Havimo file and trasmit the HaviMo1,5 Doc/calib.hex .
BUT I CAN'T TRNSMIT THE HaviMo1,5 Doc/calib.hex . AND WHEN IDID THAT I CAN'T CONNECT THE ROBOT TO THE ROBO PLUS MANAGER.
What i did wrong???
hope you have understood me problem.

Help if you can
SAKIS.
Hi hamid.

I have in my possession the Havimo2 camera and i try to connect to cm510 controller but i can't.
I wan't a few information...

First i connect the camera to cm510 and then connect the robot to roboplus manager and find the camera and the servos AX-12+ in roboplus manager.

Then i try to connect the camera with the USB2Dynamixel :
I connect the camera to TTL Possition and the switch to TTL
Then i go to Roboplus Terminal , Files- Tramsmit file -i find the Havimo file and trasmit the HaviMo1,5 Doc/calib.hex .
BUT I CAN'T TRNSMIT THE HaviMo1,5 Doc/calib.hex . AND WHEN IDID THAT I CAN'T CONNECT THE ROBOT TO THE ROBO PLUS MANAGER.
What i did wrong???
hope you have understood me problem.

Help if you can
SAKIS.
thanos79 offline
Savvy Roboteer
Savvy Roboteer
Posts: 40
Joined: Wed Mar 10, 2010 6:33 pm

Post by hamid_m » Tue Jul 13, 2010 5:24 pm

Post by hamid_m
Tue Jul 13, 2010 5:24 pm

Hi,

calib.hex is just to be used with CM5, it does not work with CM510.
I cannot understand what hardware configuration you use to connect the camera to USB2Dynamixel. In HaViMo2 calibration mode you do not need the controller any more. Just use the USB calibration software I have posted a few days ago and connect the camera to the USB2Dyn. You need to connect your camera externally to the power supply. try the following product:

http://robosavvy.com/store/product_info.php/cPath/31/products_id/505

Best regards,
Hamid.
Hi,

calib.hex is just to be used with CM5, it does not work with CM510.
I cannot understand what hardware configuration you use to connect the camera to USB2Dynamixel. In HaViMo2 calibration mode you do not need the controller any more. Just use the USB calibration software I have posted a few days ago and connect the camera to the USB2Dyn. You need to connect your camera externally to the power supply. try the following product:

http://robosavvy.com/store/product_info.php/cPath/31/products_id/505

Best regards,
Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

Post by thanos79 » Tue Jul 13, 2010 7:00 pm

Post by thanos79
Tue Jul 13, 2010 7:00 pm

Thanks for your help Hamid, i think i understand now the way to connect the camera.
I will order the SMPS2Dynamixel and i try again.

Thanks again
SAKIS :D
Thanks for your help Hamid, i think i understand now the way to connect the camera.
I will order the SMPS2Dynamixel and i try again.

Thanks again
SAKIS :D
thanos79 offline
Savvy Roboteer
Savvy Roboteer
Posts: 40
Joined: Wed Mar 10, 2010 6:33 pm

Post by thanos79 » Wed Jul 14, 2010 6:50 pm

Post by thanos79
Wed Jul 14, 2010 6:50 pm

Hi Hamid.

I wan't if it is possible your help.

As i sayed i try to connect the Havimo2 camera with USB2Dynamixel without success

After that i can't connect with the roboplus manager (RS232 FOR CM510&TTL for servo AX-12)

What i did:
First before that the robopus manager connected properly to cm510 controller.
I connect the Havimo2 to USB2Dynamixel in TTL with 3 axis cable and the switch is on TTL.
After that i download the set up for the site and try to connect but without success.
After when i saw the old video for calibration and i try to do with the Roboplus TERMINAL {Files- Transmit file -and transmit the calid.hex}
After that i have the problem

:(
Any help would be more than valyable
Regards
thanos
Hi Hamid.

I wan't if it is possible your help.

As i sayed i try to connect the Havimo2 camera with USB2Dynamixel without success

After that i can't connect with the roboplus manager (RS232 FOR CM510&TTL for servo AX-12)

What i did:
First before that the robopus manager connected properly to cm510 controller.
I connect the Havimo2 to USB2Dynamixel in TTL with 3 axis cable and the switch is on TTL.
After that i download the set up for the site and try to connect but without success.
After when i saw the old video for calibration and i try to do with the Roboplus TERMINAL {Files- Transmit file -and transmit the calid.hex}
After that i have the problem

:(
Any help would be more than valyable
Regards
thanos
thanos79 offline
Savvy Roboteer
Savvy Roboteer
Posts: 40
Joined: Wed Mar 10, 2010 6:33 pm

Post by hamid_m » Wed Jul 14, 2010 11:16 pm

Post by hamid_m
Wed Jul 14, 2010 11:16 pm

Hi Thanos,

Have you connected the module to the power supply? I described the process in my last post.

Best regards,
Hamid.
Hi Thanos,

Have you connected the module to the power supply? I described the process in my last post.

Best regards,
Hamid.
hamid_m offline
Savvy Roboteer
Savvy Roboteer
Posts: 133
Joined: Thu May 03, 2007 4:56 pm

PreviousNext
PreviousNext
261 postsPage 13 of 181 ... 10, 11, 12, 13, 14, 15, 16 ... 18
261 postsPage 13 of 181 ... 10, 11, 12, 13, 14, 15, 16 ... 18