how to test sensor?

Hitec robotics including ROBONOVA humanoid, HSR-8498HB servos, MR C-3024 Controllers and RoboBasic
3 postsPage 1 of 1
3 postsPage 1 of 1

how to test sensor?

Post by Delta » Sat Feb 23, 2013 7:53 pm

Post by Delta
Sat Feb 23, 2013 7:53 pm

hello
Need some help!! Testing Robonova Tilt sensor..After plug in in any AD port nothing work.. I have tried changeing the value also..
sample code what i am doing

robot_tilt:
A = AD(2)
IF A > 250 THEN RETURN
IF A <30> 200 THEN GOTO tilt_high

RETURN
tilt_low:
A = AD(2)
'IF A < 30 THEN GOTO forward_standup
IF A < 30 THEN GOTO backward_standup
RETURN
tilt_high:
A = AD(2)
'IF A > 200 THEN GOTO backward_standup
IF A > 200 THEN GOTO forward_standup
RETURN
when ever i used this value If A>100 THEN GOTO Tilt_high
then my robo keep standing on his belly and doing again and again....until i stop him....i dont know my sensor is not workin or i am doing something wrong......please helps
Thanks
hello
Need some help!! Testing Robonova Tilt sensor..After plug in in any AD port nothing work.. I have tried changeing the value also..
sample code what i am doing

robot_tilt:
A = AD(2)
IF A > 250 THEN RETURN
IF A <30> 200 THEN GOTO tilt_high

RETURN
tilt_low:
A = AD(2)
'IF A < 30 THEN GOTO forward_standup
IF A < 30 THEN GOTO backward_standup
RETURN
tilt_high:
A = AD(2)
'IF A > 200 THEN GOTO backward_standup
IF A > 200 THEN GOTO forward_standup
RETURN
when ever i used this value If A>100 THEN GOTO Tilt_high
then my robo keep standing on his belly and doing again and again....until i stop him....i dont know my sensor is not workin or i am doing something wrong......please helps
Thanks
Delta offline
Newbie
Newbie
Posts: 2
Joined: Tue Jan 15, 2013 12:19 am

Post by robmsong » Mon Mar 04, 2013 7:51 am

Post by robmsong
Mon Mar 04, 2013 7:51 am

Sorry,I'd like to help you stage, but I will not.
Sorry,I'd like to help you stage, but I will not.
robmsong offline
Newbie
Newbie
Posts: 2
Joined: Mon Mar 04, 2013 7:47 am

Post by voodoochile » Fri Mar 15, 2013 5:07 am

Post by voodoochile
Fri Mar 15, 2013 5:07 am

Test it on a multimeter! Apply power & probe it on the outputs, as you tilt it & see what reading you get!
Test it on a multimeter! Apply power & probe it on the outputs, as you tilt it & see what reading you get!
voodoochile offline
Newbie
Newbie
Posts: 6
Joined: Wed Mar 13, 2013 5:00 am


3 postsPage 1 of 1
3 postsPage 1 of 1
cron