Roboard WIFI module problem with WPA2

Based on DMP's Vortex processor / SoC this board is a full computer capable of running a standard Windows and Linux installation on the backpack of your robot.
3 postsPage 1 of 1
3 postsPage 1 of 1

Roboard WIFI module problem with WPA2

Post by zaphod80013 » Thu Dec 20, 2012 5:04 am

Post by zaphod80013
Thu Dec 20, 2012 5:04 am

HELP!

I have a RB-110 using the VT6655 wifi module on a Debian 6.0.6 minimal LXDE install. I can get the card to the point where iwlist scan shows me the networks in my vicinity, so presumably the card and driver are functioning correctly.

When I try to connect to my home network (access point WZR-HP-G300NH running ddwrt v24SP2 with WPA2 Personal security [which I can't realistically disable]) I get the following error which repeats until the interface is shut down.

kernel: [ 1052.702751] SIOCSIWENCODEEXT:Enable WPA WEXT SUPPORT!!!!!
kernel: [ 1059.568373] set essid to myssid
kernel: [ 1059.569619] chester-abyDesireSSID=myssid
kernel: [ 1059.569651] AP(BSS) finding:Found a AP(BSS)..
kernel: [ 1059.571409] 802.11 Authen (OPEN) Successful.
kernel: [ 1059.576098] Association Successful, AID=1.
kernel: [ 1059.576129] Link with AP(SSID): myssid
kernel: [ 1059.579619] chester-abyDesireSSID=myssid
kernel: [ 1062.802397] AP deauthed me, reason=2.


I've not been able to fine anything useful on Google, and at this point do not know if this is a driver, kernel or wpa_supplicant problem.

I also tried a Dlink DWA-131 usb dongle, compiling the latest drivers from Realtek (RTL8192SU chipset). the card only established a connection when I compiled the spa_supplicant version shipped with the driver (6.9) Debian installed 6.10.

from this I know the config is correct for my network but again the VT6655 failed with the same error. The kernel config file installed with the 2.6.34 vortex-sg kernel suggests all WEXT functions are compiled in. From this I suspect the problem is with the VT6655_stage driver but don't know what to try next.

Any help welcome.


thanks

Ray.
HELP!

I have a RB-110 using the VT6655 wifi module on a Debian 6.0.6 minimal LXDE install. I can get the card to the point where iwlist scan shows me the networks in my vicinity, so presumably the card and driver are functioning correctly.

When I try to connect to my home network (access point WZR-HP-G300NH running ddwrt v24SP2 with WPA2 Personal security [which I can't realistically disable]) I get the following error which repeats until the interface is shut down.

kernel: [ 1052.702751] SIOCSIWENCODEEXT:Enable WPA WEXT SUPPORT!!!!!
kernel: [ 1059.568373] set essid to myssid
kernel: [ 1059.569619] chester-abyDesireSSID=myssid
kernel: [ 1059.569651] AP(BSS) finding:Found a AP(BSS)..
kernel: [ 1059.571409] 802.11 Authen (OPEN) Successful.
kernel: [ 1059.576098] Association Successful, AID=1.
kernel: [ 1059.576129] Link with AP(SSID): myssid
kernel: [ 1059.579619] chester-abyDesireSSID=myssid
kernel: [ 1062.802397] AP deauthed me, reason=2.


I've not been able to fine anything useful on Google, and at this point do not know if this is a driver, kernel or wpa_supplicant problem.

I also tried a Dlink DWA-131 usb dongle, compiling the latest drivers from Realtek (RTL8192SU chipset). the card only established a connection when I compiled the spa_supplicant version shipped with the driver (6.9) Debian installed 6.10.

from this I know the config is correct for my network but again the VT6655 failed with the same error. The kernel config file installed with the 2.6.34 vortex-sg kernel suggests all WEXT functions are compiled in. From this I suspect the problem is with the VT6655_stage driver but don't know what to try next.

Any help welcome.


thanks

Ray.
zaphod80013 offline
Newbie
Newbie
Posts: 2
Joined: Wed Dec 19, 2012 4:32 pm

Re: Roboard WIFI module problem with WPA2

Post by Marsman » Sat Feb 23, 2013 7:36 pm

Post by Marsman
Sat Feb 23, 2013 7:36 pm

Hi,

I am experiencing very similar problems trying to connect to my WPA2 secure Wireless network. Driver is successfully installed and "iwlist eth8 scan" shows the desired network (among others):
Code: Select all
          Cell 02 - Address: 58:6D:8F:AE:54:DD
                    ESSID:"GTBoekerFRA"
                    Mode:Managed
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=80/100  Signal level=-58 dBm  Noise level=0 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

I reviewed a lot of tutorials, blogs, forums, etc. which gave me information how to configure the /etc/network/interfaces file:
Code: Select all
auto lo
iface lo inet loopback

auto eth8
iface eth8 inet dhcp
wpa-driver wext
wpa-ssid GTBoekerFRA
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk f47029bf30710ed6007753e0122550ae71378f853433049e0f0ef1012adf75f8

The issue I am facing is that I cannot get a valid IP address from the DHCP:
Code: Select all
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth8/00:0f:a3:7e:45:35
Sending on   LPF/eth8/00:0f:a3:7e:45:35
Sending on   Socket/fallback
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


Anyone having a clue?

I made another test to verify that my RoBoard WLAN card works ok: I temporarily created an open WLAN Hotspot with my RAZRi mobile phone without security, i.e. no password needed. So I simplified the interfaces file to:
Code: Select all
auto lo
iface lo inet loopback

auto eth8
iface eth8 inet dhcp
wireless-essid RAZRi
wireless-channel 8
wireless-mode managed

..... and it works. I can ping (e.g. to google.com) and am connected to the internet.

So why does it not work with the WPA2 network at my home?
Hi,

I am experiencing very similar problems trying to connect to my WPA2 secure Wireless network. Driver is successfully installed and "iwlist eth8 scan" shows the desired network (among others):
Code: Select all
          Cell 02 - Address: 58:6D:8F:AE:54:DD
                    ESSID:"GTBoekerFRA"
                    Mode:Managed
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=80/100  Signal level=-58 dBm  Noise level=0 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

I reviewed a lot of tutorials, blogs, forums, etc. which gave me information how to configure the /etc/network/interfaces file:
Code: Select all
auto lo
iface lo inet loopback

auto eth8
iface eth8 inet dhcp
wpa-driver wext
wpa-ssid GTBoekerFRA
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk f47029bf30710ed6007753e0122550ae71378f853433049e0f0ef1012adf75f8

The issue I am facing is that I cannot get a valid IP address from the DHCP:
Code: Select all
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth8/00:0f:a3:7e:45:35
Sending on   LPF/eth8/00:0f:a3:7e:45:35
Sending on   Socket/fallback
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 16
DHCPDISCOVER on eth8 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


Anyone having a clue?

I made another test to verify that my RoBoard WLAN card works ok: I temporarily created an open WLAN Hotspot with my RAZRi mobile phone without security, i.e. no password needed. So I simplified the interfaces file to:
Code: Select all
auto lo
iface lo inet loopback

auto eth8
iface eth8 inet dhcp
wireless-essid RAZRi
wireless-channel 8
wireless-mode managed

..... and it works. I can ping (e.g. to google.com) and am connected to the internet.

So why does it not work with the WPA2 network at my home?
Marsman offline
Robot Builder
Robot Builder
Posts: 13
Joined: Sun Sep 27, 2009 9:47 am

Re: Roboard WIFI module problem with WPA2

Post by zaphod80013 » Wed Feb 27, 2013 2:04 am

Post by zaphod80013
Wed Feb 27, 2013 2:04 am

Marsman,

This is basically the same symptoms I was seeing, If I turn off WPA2 the Roboad connects fine and receives an address. You can verify your DHCP configuration by turning off WPA2 as a test, that will at least prove (or not) that the problem is in the wireless security rather than the DHCP configuration.

BTW: Unless you posted a dummy PSK here you may want to change your WPA2 key, admittedly low risk as somebody would need to know your location to use the key but It's probably not a good idea to post cipher keys or mac addresses.

If I have the time this weekend I was going to try to create a CrunchBang install for the Roboard (Debian 7 based i486 distro), If I have any better luck with the wireless I'll post here.
Marsman,

This is basically the same symptoms I was seeing, If I turn off WPA2 the Roboad connects fine and receives an address. You can verify your DHCP configuration by turning off WPA2 as a test, that will at least prove (or not) that the problem is in the wireless security rather than the DHCP configuration.

BTW: Unless you posted a dummy PSK here you may want to change your WPA2 key, admittedly low risk as somebody would need to know your location to use the key but It's probably not a good idea to post cipher keys or mac addresses.

If I have the time this weekend I was going to try to create a CrunchBang install for the Roboard (Debian 7 based i486 distro), If I have any better luck with the wireless I'll post here.
zaphod80013 offline
Newbie
Newbie
Posts: 2
Joined: Wed Dec 19, 2012 4:32 pm


3 postsPage 1 of 1
3 postsPage 1 of 1