Serial Communication Error

Bioloid robot kit from Korean company Robotis; CM5 controller block, AX12 servos..
2 postsPage 1 of 1
2 postsPage 1 of 1

Serial Communication Error

Post by dnhan » Sat Jan 12, 2013 12:51 am

Post by dnhan
Sat Jan 12, 2013 12:51 am

I'm attempting to control the Bioloid robot now using the wireless Zigbee module now but I'm running into some new errors now. I've written a very simple code just to test the wireless communication as shown below:

Code: Select all
 
START PROGRAM {
       
      ENDLESSLOOP{

                if(REMOCONARRIVED == TRUE){
                     MOTIONPAGE = 7
                 }

      }


}



In this case motionpage = 7 is the demo page for Bioloid dog standing up. However when I try to transmit the command through Roboplus terminal the Bioloid does not seem to respond to it at all.

I currently have one Zigbee module attached to the CM-5 board, and the other is mounted on the Zig2Serial attached to the USB2Dynamixel which is attached to my computer. After connecting through the appropriate COM port (COM 6 for me), I try pressing a few buttons in Roboplus Terminal. The TxD light on the Zig2Serial flash followed by the RxD light on the CM-5 however the Bioloid does not respond. Can anyone help with this?

Note the status light on the Zig2Serial is solid and the serial cable is not plugged into the CM-5 at this time.
I'm attempting to control the Bioloid robot now using the wireless Zigbee module now but I'm running into some new errors now. I've written a very simple code just to test the wireless communication as shown below:

Code: Select all
 
START PROGRAM {
       
      ENDLESSLOOP{

                if(REMOCONARRIVED == TRUE){
                     MOTIONPAGE = 7
                 }

      }


}



In this case motionpage = 7 is the demo page for Bioloid dog standing up. However when I try to transmit the command through Roboplus terminal the Bioloid does not seem to respond to it at all.

I currently have one Zigbee module attached to the CM-5 board, and the other is mounted on the Zig2Serial attached to the USB2Dynamixel which is attached to my computer. After connecting through the appropriate COM port (COM 6 for me), I try pressing a few buttons in Roboplus Terminal. The TxD light on the Zig2Serial flash followed by the RxD light on the CM-5 however the Bioloid does not respond. Can anyone help with this?

Note the status light on the Zig2Serial is solid and the serial cable is not plugged into the CM-5 at this time.
dnhan offline
Newbie
Newbie
Posts: 3
Joined: Mon Dec 03, 2012 7:16 pm

Post by Fritzoid » Mon Jan 14, 2013 2:22 pm

Post by Fritzoid
Mon Jan 14, 2013 2:22 pm

dnhan,

When you RoboPlus Task checks for REMOCONARRIVED the following action occurs. The input buffer is scanned to see if there is a valid remote control communications packet present. If a packet is present the two-byte code is saved for later retrieval and the REMOCONARRIVED flag is set to true. If you transmit unformatted data it will be skipped over when the program searches for the 0xFF, 0x55 packet header.

See this page for information about remote control data packets. http://support.robotis.com/en/product/auxdevice/communication/rc100_manual.htm.
dnhan,

When you RoboPlus Task checks for REMOCONARRIVED the following action occurs. The input buffer is scanned to see if there is a valid remote control communications packet present. If a packet is present the two-byte code is saved for later retrieval and the REMOCONARRIVED flag is set to true. If you transmit unformatted data it will be skipped over when the program searches for the 0xFF, 0x55 packet header.

See this page for information about remote control data packets. http://support.robotis.com/en/product/auxdevice/communication/rc100_manual.htm.
Fritzoid offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 331
Joined: Mon Dec 18, 2006 1:00 am


2 postsPage 1 of 1
2 postsPage 1 of 1