Legs in neutral position

Hitec robotics including ROBONOVA humanoid, HSR-8498HB servos, MR C-3024 Controllers and RoboBasic
9 postsPage 1 of 1
9 postsPage 1 of 1

Legs in neutral position

Post by subpilot » Fri Mar 03, 2006 9:42 pm

Post by subpilot
Fri Mar 03, 2006 9:42 pm

When I put my Robonova together there was something odd about the legs. On page 13 they state that the legs must fold completely. The indexing on the knee joint does not seem to agree. When I run the example code the default leg position makes the knee bend backwards. Did anyone else encounter this?
When I put my Robonova together there was something odd about the legs. On page 13 they state that the legs must fold completely. The indexing on the knee joint does not seem to agree. When I run the example code the default leg position makes the knee bend backwards. Did anyone else encounter this?
subpilot offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 146
Joined: Sat Feb 25, 2006 1:00 am
Location: Lake Arrowhead, Ca,USA

Post by Pev » Fri Mar 03, 2006 10:02 pm

Post by Pev
Fri Mar 03, 2006 10:02 pm

Haven't had this issue, mine lets the legs fold down completely. Do you have a photo of the leg in the position you describe.

Carl
Haven't had this issue, mine lets the legs fold down completely. Do you have a photo of the leg in the position you describe.

Carl
Pev offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 547
Joined: Sun Feb 26, 2006 1:00 am
Location: UK

Post by bauermech » Sat Mar 04, 2006 3:15 am

Post by bauermech
Sat Mar 04, 2006 3:15 am

Yeah, that is strange.... It's with both knees? Sounds like the servo-motors are backwards, switched, or something...
Likewise, without seeing it, it's a shot in the dark... Here are some blind suggestions:
(1) Make sure the brackets (two HR1B-0003's) are offset where the two knee servos attach to each other. I almost didn't do it when putting mine together.
(2) Be sure the screw placements coincide with the correct servo horn numbers...

Knee to Thigh (Right/Left):
8 2
6 2 8 4
4 6

Knee to Shin (Right/Left):
4 6
2 6 4 8
8 2

I don't know, just some thoughts... post a pic if it's none of these help.
Yeah, that is strange.... It's with both knees? Sounds like the servo-motors are backwards, switched, or something...
Likewise, without seeing it, it's a shot in the dark... Here are some blind suggestions:
(1) Make sure the brackets (two HR1B-0003's) are offset where the two knee servos attach to each other. I almost didn't do it when putting mine together.
(2) Be sure the screw placements coincide with the correct servo horn numbers...

Knee to Thigh (Right/Left):
8 2
6 2 8 4
4 6

Knee to Shin (Right/Left):
4 6
2 6 4 8
8 2

I don't know, just some thoughts... post a pic if it's none of these help.
bauermech offline
Site Admin
Site Admin
User avatar
Posts: 318
Joined: Sat Feb 04, 2006 1:00 am
Location: Defiance, Ohio, USA

Post by bauermech » Sat Mar 04, 2006 3:22 am

Post by bauermech
Sat Mar 04, 2006 3:22 am

oh crap... that didn't work so well.
it's:
knee/thigh (R-L):
__8__..__2__
_6_2_.._8_4_
__4__..__6__

knee/shin (R-L):
__4__..__6__
_2_6_.._4_8_
__8__..__2__

R and L are the robot's right and left
Confusing? It is to me now :wink:
Hope this helps
oh crap... that didn't work so well.
it's:
knee/thigh (R-L):
__8__..__2__
_6_2_.._8_4_
__4__..__6__

knee/shin (R-L):
__4__..__6__
_2_6_.._4_8_
__8__..__2__

R and L are the robot's right and left
Confusing? It is to me now :wink:
Hope this helps
bauermech offline
Site Admin
Site Admin
User avatar
Posts: 318
Joined: Sat Feb 04, 2006 1:00 am
Location: Defiance, Ohio, USA

Post by subpilot » Sat Mar 04, 2006 7:10 pm

Post by subpilot
Sat Mar 04, 2006 7:10 pm

I don't get it and the drawing doesn't help. If you put your leg straight like this:

Image

What index position is the top screw at on the three joints (I marked them as 1,2,3) on each leg. Right being the same as what you'd call your right leg.

I have R1=1, R2=4, R3=5 L1=1, L2=6, L3=5
I don't get it and the drawing doesn't help. If you put your leg straight like this:

Image

What index position is the top screw at on the three joints (I marked them as 1,2,3) on each leg. Right being the same as what you'd call your right leg.

I have R1=1, R2=4, R3=5 L1=1, L2=6, L3=5
subpilot offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 146
Joined: Sat Feb 25, 2006 1:00 am
Location: Lake Arrowhead, Ca,USA

Post by bauermech » Sun Mar 05, 2006 1:14 am

Post by bauermech
Sun Mar 05, 2006 1:14 am

Hmmm... this is what I've got...

The robot's left leg:
L1>2, L2>6, L3>4

Robot's right leg:
R1>8, R2>4, R3>6

Each of these indicates the top screw (as though he were standing upright) in refrence to the numbers on the servo horn disks

Here's what he looks like on his belly...
Image

If this isn't what you're looking for, or still doesn't help, let me know. Do you have a picture of what the legs look like when you 'fold' them up together ...or at least as far as you can get them to fold?
Hmmm... this is what I've got...

The robot's left leg:
L1>2, L2>6, L3>4

Robot's right leg:
R1>8, R2>4, R3>6

Each of these indicates the top screw (as though he were standing upright) in refrence to the numbers on the servo horn disks

Here's what he looks like on his belly...
Image

If this isn't what you're looking for, or still doesn't help, let me know. Do you have a picture of what the legs look like when you 'fold' them up together ...or at least as far as you can get them to fold?
bauermech offline
Site Admin
Site Admin
User avatar
Posts: 318
Joined: Sat Feb 04, 2006 1:00 am
Location: Defiance, Ohio, USA

Post by subpilot » Sun Mar 05, 2006 2:50 am

Post by subpilot
Sun Mar 05, 2006 2:50 am

That's quite the bit of graphics you did there bauermech. Thanks.
Pev, does that match what you have?

I don't get the instructions. They say:
The left leg is assembled exactly the same as the right leg. Note the position of the numbers on the servo horns during assembly.


Clearly that can't be true, can it?
That's quite the bit of graphics you did there bauermech. Thanks.
Pev, does that match what you have?

I don't get the instructions. They say:
The left leg is assembled exactly the same as the right leg. Note the position of the numbers on the servo horns during assembly.


Clearly that can't be true, can it?
subpilot offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 146
Joined: Sat Feb 25, 2006 1:00 am
Location: Lake Arrowhead, Ca,USA

Post by Pev » Sun Mar 05, 2006 10:43 am

Post by Pev
Sun Mar 05, 2006 10:43 am

Just checked mine and the values are the same as those Bauermech has posted.

Hope that helps

Pev
Just checked mine and the values are the same as those Bauermech has posted.

Hope that helps

Pev
Pev offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 547
Joined: Sun Feb 26, 2006 1:00 am
Location: UK

Post by subpilot » Sun Mar 05, 2006 7:52 pm

Post by subpilot
Sun Mar 05, 2006 7:52 pm

Ah, much better. I had tweaked values to compenstae but it never seemed right. It's all good now.
Ah, much better. I had tweaked values to compenstae but it never seemed right. It's all good now.
subpilot offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 146
Joined: Sat Feb 25, 2006 1:00 am
Location: Lake Arrowhead, Ca,USA


9 postsPage 1 of 1
9 postsPage 1 of 1
cron