Forum RSS fixed :)

News and announcements related to Humanoids/walkers, robo-one/other conferences, intelligent servos, advanced robot controllers/sensors, and interesting new humanoid related developments.
8 postsPage 1 of 1
8 postsPage 1 of 1

Forum RSS fixed :)

Post by PedroR » Tue Jul 01, 2008 1:30 pm

Post by PedroR
Tue Jul 01, 2008 1:30 pm

Hi guys

For those of you who don't know me yet, my name is Pedro and I've come to work with Robosavvy and Limor a few months ago.

I wanted to let you know that we have finaly fixed the forum RSS. It somtimes didn't work due to some UTF8 formating issues.

Anyway, after several hours testing and debugging it is now fixed (hopefully) and you can now subscribe to the newsfeed and see evertything that's happening on the forums.
If you still experience problems with the RSS let me know at pedro@robosavvy.com.

[]
Pedro.
Hi guys

For those of you who don't know me yet, my name is Pedro and I've come to work with Robosavvy and Limor a few months ago.

I wanted to let you know that we have finaly fixed the forum RSS. It somtimes didn't work due to some UTF8 formating issues.

Anyway, after several hours testing and debugging it is now fixed (hopefully) and you can now subscribe to the newsfeed and see evertything that's happening on the forums.
If you still experience problems with the RSS let me know at pedro@robosavvy.com.

[]
Pedro.
PedroR offline
Savvy Roboteer
Savvy Roboteer
Posts: 1199
Joined: Mon Jun 16, 2008 11:07 pm

Re: Forum RSS fixed :)

Post by tempusmaster » Mon Jul 14, 2008 2:02 pm

Post by tempusmaster
Mon Jul 14, 2008 2:02 pm

Thanks Pedro!!!

That's much, much better! I like it a lot.

The only thing better would be if we could get separate RSS feeds for each of the forums. Personally, I read them all, but some folks may only be interested in one particular robot type.

Keep up the good work.
Thanks Pedro!!!

That's much, much better! I like it a lot.

The only thing better would be if we could get separate RSS feeds for each of the forums. Personally, I read them all, but some folks may only be interested in one particular robot type.

Keep up the good work.
Latest robot news, information, reviews, hacks, photos, and videos - with special on-site coverage from Japan
http://www.robots-dreams.com
tempusmaster offline
Site Admin
Site Admin
User avatar
Posts: 532
Joined: Thu Oct 27, 2005 1:00 am

Post by BillB » Mon Jul 14, 2008 3:06 pm

Post by BillB
Mon Jul 14, 2008 3:06 pm

While we are on the subject of enhancing RoboSavvy, could I suggest that you consider extending the "Whats new in the forum" part of the front page.

At the moment I always use the "View posts since last visit" view, but unfortuately (but understandably) this has a habit of timing out too quickly. So if I get distracted while catching on all the posts (following links, family, sleep etc.) when I come back to the "View posts since last visit" the list has changed because it is using my last visit as the new search criteria even though I did not manage to read all the posts on my last visit.

I would really, really appreciate a view that lists all the recent posts, say for the last month. Similar to the Whats new in the forum" part of the front page - but extended.
While we are on the subject of enhancing RoboSavvy, could I suggest that you consider extending the "Whats new in the forum" part of the front page.

At the moment I always use the "View posts since last visit" view, but unfortuately (but understandably) this has a habit of timing out too quickly. So if I get distracted while catching on all the posts (following links, family, sleep etc.) when I come back to the "View posts since last visit" the list has changed because it is using my last visit as the new search criteria even though I did not manage to read all the posts on my last visit.

I would really, really appreciate a view that lists all the recent posts, say for the last month. Similar to the Whats new in the forum" part of the front page - but extended.
BillB offline
Savvy Roboteer
Savvy Roboteer
User avatar
Posts: 232
Joined: Sun Aug 06, 2006 1:00 am
Location: Hampshire, UK

Post by PedroR » Wed Jul 16, 2008 12:37 am

Post by PedroR
Wed Jul 16, 2008 12:37 am

Hi TempusMaster and BillB

1) Regarding RSS for specific forums that feature is available but currently the forum is not advertising it in a manner that browsers can recognize it. It's a nice suggestion though so I will look into advertising it propperlly for browsers as soon as possible. In the meantime if you want to view RSS for a specific thread use this address:
http://robosavvy.com/forum/rss.php?f=FORUMID

To find the FORUMID, hover the link for the forum you want, in the index page of the forum. The link should end in f=.... The number you need (FORUMID) is the number that comes after f=.


2) regarding the cookie timeout this is the status: in the past Limor installed a Joomla/phpBB bridge. This means there is only one authentication system and very good integration.
This is really nice but has some drawbacks that were not evident at the time of the installation. The drawbacks are basically all cookie related in some way or another because integration is accomplished with several hacks on the cookies.
I will look into the situation you point out asap.
I appreciate your feedback about this issue since I was unaware of this specific problem (I am aware of several others though, also with the same cause).

If you find any other items that could be improved please let me know!

Thanks
Pedro
Hi TempusMaster and BillB

1) Regarding RSS for specific forums that feature is available but currently the forum is not advertising it in a manner that browsers can recognize it. It's a nice suggestion though so I will look into advertising it propperlly for browsers as soon as possible. In the meantime if you want to view RSS for a specific thread use this address:
http://robosavvy.com/forum/rss.php?f=FORUMID

To find the FORUMID, hover the link for the forum you want, in the index page of the forum. The link should end in f=.... The number you need (FORUMID) is the number that comes after f=.


2) regarding the cookie timeout this is the status: in the past Limor installed a Joomla/phpBB bridge. This means there is only one authentication system and very good integration.
This is really nice but has some drawbacks that were not evident at the time of the installation. The drawbacks are basically all cookie related in some way or another because integration is accomplished with several hacks on the cookies.
I will look into the situation you point out asap.
I appreciate your feedback about this issue since I was unaware of this specific problem (I am aware of several others though, also with the same cause).

If you find any other items that could be improved please let me know!

Thanks
Pedro
PedroR offline
Savvy Roboteer
Savvy Roboteer
Posts: 1199
Joined: Mon Jun 16, 2008 11:07 pm

Post by tempusmaster » Thu Jul 17, 2008 11:02 am

Post by tempusmaster
Thu Jul 17, 2008 11:02 am

Hi Pedro,

Thanks for the helpful info! It will be quite useful.

Here's a "problem" for you - When I receive an email notification that a new post has been made on a thread I'm tracking, there is a link included. It always has the proper url to the post, but when I click on it, they always take me to the top page in the forum. Then, if I manually paste the url into my address bar, it takes me to the correct post.

Any clue what's going on? I admit, it might be a problem on my end, though it does the same thing on all three computers that I use regularly.

All the best,

Lem
Hi Pedro,

Thanks for the helpful info! It will be quite useful.

Here's a "problem" for you - When I receive an email notification that a new post has been made on a thread I'm tracking, there is a link included. It always has the proper url to the post, but when I click on it, they always take me to the top page in the forum. Then, if I manually paste the url into my address bar, it takes me to the correct post.

Any clue what's going on? I admit, it might be a problem on my end, though it does the same thing on all three computers that I use regularly.

All the best,

Lem
Latest robot news, information, reviews, hacks, photos, and videos - with special on-site coverage from Japan
http://www.robots-dreams.com
tempusmaster offline
Site Admin
Site Admin
User avatar
Posts: 532
Joined: Thu Oct 27, 2005 1:00 am

Post by PedroR » Thu Jul 17, 2008 11:22 am

Post by PedroR
Thu Jul 17, 2008 11:22 am

Hi tempusmaster

That's a known problem. It's also related to cookies and the joomla/php integration.

I've tried to fix a while ago but it's quite hard because the integration code is cryptic(!) and in the meantime more urgent stuff came up.

This is also an issue that affects the "What's new in forum" on the first page... People often get directed to the forum index instead of the post advertised.

Here's a trick for you: when you click on the link on your email once and you will get redirected to the forum index. After the redirect to the forum index, the correct cookie is set on your browser. Keep the forum index window open and go back to your email.
Click again on the link and this second time you will be sent to the correct place/forum post.

Any subsequent forum posts/ links that you click will work correctly as long as you keep at least one window of the forum open.

This is strange behavior and I will look into fixing it as soon as possible.

Thanks
Pedro.
Hi tempusmaster

That's a known problem. It's also related to cookies and the joomla/php integration.

I've tried to fix a while ago but it's quite hard because the integration code is cryptic(!) and in the meantime more urgent stuff came up.

This is also an issue that affects the "What's new in forum" on the first page... People often get directed to the forum index instead of the post advertised.

Here's a trick for you: when you click on the link on your email once and you will get redirected to the forum index. After the redirect to the forum index, the correct cookie is set on your browser. Keep the forum index window open and go back to your email.
Click again on the link and this second time you will be sent to the correct place/forum post.

Any subsequent forum posts/ links that you click will work correctly as long as you keep at least one window of the forum open.

This is strange behavior and I will look into fixing it as soon as possible.

Thanks
Pedro.
PedroR offline
Savvy Roboteer
Savvy Roboteer
Posts: 1199
Joined: Mon Jun 16, 2008 11:07 pm

Post by PedroR » Thu Jul 31, 2008 9:18 pm

Post by PedroR
Thu Jul 31, 2008 9:18 pm

we have now updated both phpBB and the joomla/phpBB integration to the latest versions.
I have also manually extended the cookie timeout to 27 hours.

from our preliminary testing things seem to have improved but I would very much appreciate your feedback about this.
Is your user experience on robosavvy improving? have we been able to address all your issues?

I will be waiting for your feedback :).

Thanks
Pedro.
we have now updated both phpBB and the joomla/phpBB integration to the latest versions.
I have also manually extended the cookie timeout to 27 hours.

from our preliminary testing things seem to have improved but I would very much appreciate your feedback about this.
Is your user experience on robosavvy improving? have we been able to address all your issues?

I will be waiting for your feedback :).

Thanks
Pedro.
PedroR offline
Savvy Roboteer
Savvy Roboteer
Posts: 1199
Joined: Mon Jun 16, 2008 11:07 pm

Post by tempusmaster » Fri Aug 01, 2008 3:37 am

Post by tempusmaster
Fri Aug 01, 2008 3:37 am

PedroR wrote:we have now updated both phpBB and the joomla/phpBB integration to the latest versions.
I have also manually extended the cookie timeout to 27 hours.

from our preliminary testing things seem to have improved but I would very much appreciate your feedback about this.
Is your user experience on robosavvy improving? have we been able to address all your issues?

I will be waiting for your feedback :).

Thanks
Pedro.


Well, it's only a sample of one, but at least now on this computer the links from the email alerts take me directly to the correct post. 8)

As for the RoboSavvy user experience, it's always great! :D

Thanks for all your help.
PedroR wrote:we have now updated both phpBB and the joomla/phpBB integration to the latest versions.
I have also manually extended the cookie timeout to 27 hours.

from our preliminary testing things seem to have improved but I would very much appreciate your feedback about this.
Is your user experience on robosavvy improving? have we been able to address all your issues?

I will be waiting for your feedback :).

Thanks
Pedro.


Well, it's only a sample of one, but at least now on this computer the links from the email alerts take me directly to the correct post. 8)

As for the RoboSavvy user experience, it's always great! :D

Thanks for all your help.
Latest robot news, information, reviews, hacks, photos, and videos - with special on-site coverage from Japan
http://www.robots-dreams.com
tempusmaster offline
Site Admin
Site Admin
User avatar
Posts: 532
Joined: Thu Oct 27, 2005 1:00 am


8 postsPage 1 of 1
8 postsPage 1 of 1
cron