Ubuntu shutdown problem on Ebox 3350

Based on DMP's Vortex processor / SoC this board is a full computer capable of running a standard Windows and Linux installation on the backpack of your robot.
8 postsPage 1 of 1
8 postsPage 1 of 1

Ubuntu shutdown problem on Ebox 3350

Post by tankslappa » Sun Aug 21, 2011 6:32 am

Post by tankslappa
Sun Aug 21, 2011 6:32 am

Hi,

I've been playing about with an Ebox 3350, and have installed Ubuntu 10.04 on it, and the 2.6.34.10 custom kernel onto it. Everything seems to be working fine except the shutdown.

When shutting down from the Gnome desktop, or via "shutdown now", it goes through all the usual steps, and then announces it has reached halt. The machine however remains on.

As I intend to eventually use this in a monitor free configuration (gnome and X will get stripped out), I need it to turn itself off when told. There will be no way for me to know that it has reached a state where it is safe to turn off without carrying a monitor about with me all the time.

I've checked, and I have the latest A61 BIOS.

Any ideas?
Hi,

I've been playing about with an Ebox 3350, and have installed Ubuntu 10.04 on it, and the 2.6.34.10 custom kernel onto it. Everything seems to be working fine except the shutdown.

When shutting down from the Gnome desktop, or via "shutdown now", it goes through all the usual steps, and then announces it has reached halt. The machine however remains on.

As I intend to eventually use this in a monitor free configuration (gnome and X will get stripped out), I need it to turn itself off when told. There will be no way for me to know that it has reached a state where it is safe to turn off without carrying a monitor about with me all the time.

I've checked, and I have the latest A61 BIOS.

Any ideas?
tankslappa offline
Newbie
Newbie
Posts: 5
Joined: Sun Aug 21, 2011 6:23 am

Re: Ubuntu shutdown problem on Ebox 3350

Post by roboard » Thu Sep 01, 2011 12:17 pm

Post by roboard
Thu Sep 01, 2011 12:17 pm

Auto poweroff of ebox 3350MX is based on APM. You may check whether the APM setting of your Ubuntu is correctly configured.

:)
Auto poweroff of ebox 3350MX is based on APM. You may check whether the APM setting of your Ubuntu is correctly configured.

:)
roboard offline
Savvy Roboteer
Savvy Roboteer
Posts: 302
Joined: Fri Jul 03, 2009 4:44 am

Post by tankslappa » Mon Sep 19, 2011 2:55 pm

Post by tankslappa
Mon Sep 19, 2011 2:55 pm

Ah, sorry, only just seen this reply. I don't think the email notification of replies is working (or wasn't working at the time).

I will have a look into the APM, although I might be coming back for some handholding as Linux isn't my primary OS.
Ah, sorry, only just seen this reply. I don't think the email notification of replies is working (or wasn't working at the time).

I will have a look into the APM, although I might be coming back for some handholding as Linux isn't my primary OS.
tankslappa offline
Newbie
Newbie
Posts: 5
Joined: Sun Aug 21, 2011 6:23 am

Can't get APM to work on 3350

Post by tankslappa » Thu Sep 29, 2011 1:53 am

Post by tankslappa
Thu Sep 29, 2011 1:53 am

I've been playing about, but can't get the 3350 to shutdown. It will reboot currently, but when told to shutdown it eventually just gets to halt on the screen. I need it to turn off as it will be running screen-less.

I installed Ubuntu 10.04, then replaced the kernel with 2.6.34.10-vortex86-sg kernel.

The kernel is in an confirmed working. Sound, network etc all okay.

I looked in Synaptic for apm, and all I saw was apmd. I installed it, and followed the instructions to include apm=on in the grub2 kernel options.

It also says "You need to compile a kernel with apm support enabled to use this package". This is something I can't do.

If I type "apmd" at the command line I get "No APM support in kernel"

So any ideas? Has anyone else managed to get apm working with Ubuntu 10.04?

If I do have to recompile the kernel, can someone please instruct me how to do this? Step by step idiot level please!
I've been playing about, but can't get the 3350 to shutdown. It will reboot currently, but when told to shutdown it eventually just gets to halt on the screen. I need it to turn off as it will be running screen-less.

I installed Ubuntu 10.04, then replaced the kernel with 2.6.34.10-vortex86-sg kernel.

The kernel is in an confirmed working. Sound, network etc all okay.

I looked in Synaptic for apm, and all I saw was apmd. I installed it, and followed the instructions to include apm=on in the grub2 kernel options.

It also says "You need to compile a kernel with apm support enabled to use this package". This is something I can't do.

If I type "apmd" at the command line I get "No APM support in kernel"

So any ideas? Has anyone else managed to get apm working with Ubuntu 10.04?

If I do have to recompile the kernel, can someone please instruct me how to do this? Step by step idiot level please!
tankslappa offline
Newbie
Newbie
Posts: 5
Joined: Sun Aug 21, 2011 6:23 am

Re: Can't get APM to work on 3350

Post by eried » Thu Sep 29, 2011 8:25 am

Post by eried
Thu Sep 29, 2011 8:25 am

tankslappa wrote:I've been playing about, but can't get the 3350 to shutdown. It will reboot currently, but when told to shutdown it eventually just gets to halt on the screen. I need it to turn off as it will be running screen-less.

I installed Ubuntu 10.04, then replaced the kernel with 2.6.34.10-vortex86-sg kernel.

The kernel is in an confirmed working. Sound, network etc all okay.

I looked in Synaptic for apm, and all I saw was apmd. I installed it, and followed the instructions to include apm=on in the grub2 kernel options.

It also says "You need to compile a kernel with apm support enabled to use this package". This is something I can't do.

If I type "apmd" at the command line I get "No APM support in kernel"

So any ideas? Has anyone else managed to get apm working with Ubuntu 10.04?

If I do have to recompile the kernel, can someone please instruct me how to do this? Step by step idiot level please!


I think is more like a hardware issue. The power can't be turned off completelly as in a atx machine (this is a power supply 'feature' signaled by the motherboard) but in this case the power supply is just a usb adaptor.

What's the purpose of turning off the machine? I noticed that the unit uses very little power in the last shutdown state (when actually should be turned off) so maybe a smart anti standby plug can detect this.
tankslappa wrote:I've been playing about, but can't get the 3350 to shutdown. It will reboot currently, but when told to shutdown it eventually just gets to halt on the screen. I need it to turn off as it will be running screen-less.

I installed Ubuntu 10.04, then replaced the kernel with 2.6.34.10-vortex86-sg kernel.

The kernel is in an confirmed working. Sound, network etc all okay.

I looked in Synaptic for apm, and all I saw was apmd. I installed it, and followed the instructions to include apm=on in the grub2 kernel options.

It also says "You need to compile a kernel with apm support enabled to use this package". This is something I can't do.

If I type "apmd" at the command line I get "No APM support in kernel"

So any ideas? Has anyone else managed to get apm working with Ubuntu 10.04?

If I do have to recompile the kernel, can someone please instruct me how to do this? Step by step idiot level please!


I think is more like a hardware issue. The power can't be turned off completelly as in a atx machine (this is a power supply 'feature' signaled by the motherboard) but in this case the power supply is just a usb adaptor.

What's the purpose of turning off the machine? I noticed that the unit uses very little power in the last shutdown state (when actually should be turned off) so maybe a smart anti standby plug can detect this.
eried offline
Robot Builder
Robot Builder
Posts: 15
Joined: Sun Aug 07, 2011 9:02 am

Re: Can't get APM to work on 3350

Post by roboard » Thu Sep 29, 2011 8:28 am

Post by roboard
Thu Sep 29, 2011 8:28 am

Hi,

Due to the default settings of grub2, the APM shutdown doesn't work directly on Ubuntu 10.04.
We have to do something as below :

1. Open terminal
2. Edit /etc/grub.d/10_linux
3. Find & Modify

"linux" -> "linux16"
"initrd" -> "initrd16"

Image

4. Save & Exit
5. Execute "sudo update-grub" command in terminal
6. Reboot system

Above, the APM shutdown should work correctly.
Try to shutdown it again :)
Hi,

Due to the default settings of grub2, the APM shutdown doesn't work directly on Ubuntu 10.04.
We have to do something as below :

1. Open terminal
2. Edit /etc/grub.d/10_linux
3. Find & Modify

"linux" -> "linux16"
"initrd" -> "initrd16"

Image

4. Save & Exit
5. Execute "sudo update-grub" command in terminal
6. Reboot system

Above, the APM shutdown should work correctly.
Try to shutdown it again :)
roboard offline
Savvy Roboteer
Savvy Roboteer
Posts: 302
Joined: Fri Jul 03, 2009 4:44 am

Post by tankslappa » Thu Sep 29, 2011 6:30 pm

Post by tankslappa
Thu Sep 29, 2011 6:30 pm

Thanks I'll give that a try.

To answer eried's question, the 3350 is going to be deployed screen-less and all access will be done remotely. If the box needs to be unplugged so it can be moved then it needs to be shutdown. This can be down remotely, but you can't tell if it has finished if the power light is still sitting there shining away. it need to actually reach a full shutdown state.
Thanks I'll give that a try.

To answer eried's question, the 3350 is going to be deployed screen-less and all access will be done remotely. If the box needs to be unplugged so it can be moved then it needs to be shutdown. This can be down remotely, but you can't tell if it has finished if the power light is still sitting there shining away. it need to actually reach a full shutdown state.
tankslappa offline
Newbie
Newbie
Posts: 5
Joined: Sun Aug 21, 2011 6:23 am

Post by atma » Tue Oct 25, 2011 9:42 pm

Post by atma
Tue Oct 25, 2011 9:42 pm

could you supply me an output from the command in Ubuntu linux:

"lspci" ?

thanks
could you supply me an output from the command in Ubuntu linux:

"lspci" ?

thanks
atma offline
Newbie
Newbie
Posts: 5
Joined: Fri Oct 21, 2011 8:45 pm


8 postsPage 1 of 1
8 postsPage 1 of 1