I2C comunication problem

Based on DMP's Vortex processor / SoC this board is a full computer capable of running a standard Windows and Linux installation on the backpack of your robot.
3 postsPage 1 of 1
3 postsPage 1 of 1

I2C comunication problem

Post by Andy2011 » Thu May 05, 2011 12:49 pm

Post by Andy2011
Thu May 05, 2011 12:49 pm

Hello

My name is Andreu and i am just starting to use the I2C protocol with the roboard. I want to use it to connect a brushlees motor with a Driver I2C to the roboard.

When i try to use the functions to look for the adress of my driver:

i2c0master_StartN
i2c0master_WriteN

It gives me error number 620.

I search for it in the library and i can not find what this error means(there is an error 620 en the function i2c0master_Reset but i am not using it)


Anyone can help me?

Thank you very much for your time.
Hello

My name is Andreu and i am just starting to use the I2C protocol with the roboard. I want to use it to connect a brushlees motor with a Driver I2C to the roboard.

When i try to use the functions to look for the adress of my driver:

i2c0master_StartN
i2c0master_WriteN

It gives me error number 620.

I search for it in the library and i can not find what this error means(there is an error 620 en the function i2c0master_Reset but i am not using it)


Anyone can help me?

Thank you very much for your time.
Andy2011 offline
Newbie
Newbie
Posts: 5
Joined: Thu Apr 07, 2011 10:04 am

Re: I2C comunication problem

Post by roboard » Thu May 05, 2011 1:06 pm

Post by roboard
Thu May 05, 2011 1:06 pm

Hi,

you can use roboio_GetErrMsg() to see what error happen. And we suggest that you use the new I2C API of RoBoIO 1.7: i2c_Send(), i2c_Receive(), i2c_SensorRead() to access your I2C devices.

:)
Hi,

you can use roboio_GetErrMsg() to see what error happen. And we suggest that you use the new I2C API of RoBoIO 1.7: i2c_Send(), i2c_Receive(), i2c_SensorRead() to access your I2C devices.

:)
roboard offline
Savvy Roboteer
Savvy Roboteer
Posts: 302
Joined: Fri Jul 03, 2009 4:44 am

Post by Andy2011 » Thu May 05, 2011 3:00 pm

Post by Andy2011
Thu May 05, 2011 3:00 pm

Thank you very much,

It says that the I2C is not answering but the function i2c0master_StartN returns a true value in some moment. Seems like it finds the adress of the driver but then it changes, still i think i will studied further to see if i find the answer.

Thank you very much.
Thank you very much,

It says that the I2C is not answering but the function i2c0master_StartN returns a true value in some moment. Seems like it finds the adress of the driver but then it changes, still i think i will studied further to see if i find the answer.

Thank you very much.
Andy2011 offline
Newbie
Newbie
Posts: 5
Joined: Thu Apr 07, 2011 10:04 am


3 postsPage 1 of 1
3 postsPage 1 of 1