I/O library fails to initialize (windows xp)

Based on DMP's Vortex processor / SoC this board is a full computer capable of running a standard Windows and Linux installation on the backpack of your robot.
4 postsPage 1 of 1
4 postsPage 1 of 1

I/O library fails to initialize (windows xp)

Post by snest » Tue Oct 12, 2010 5:20 am

Post by snest
Tue Oct 12, 2010 5:20 am

Hello,
I am trying to run a simple PWM program on windows xp:

Code: Select all

#include "stdafx.h"
#include "iostream"
#include "roboard_dll.h"

#include <stdio>
#include <string>
#include <stdlib>

using namespace System;
using namespace std;

int main(array<System> ^args)
{
      
    int channel = 0;
   unsigned long usedchannel;
    unsigned long period  = 20000;
    unsigned long duty    = 1000;
    unsigned long count   = 300;

   usedchannel = RCSERVO_USECHANNEL0 + RCSERVO_USECHANNEL1 + RCSERVO_USECHANNEL2 + RCSERVO_USECHANNEL3 + RCSERVO_USECHANNEL4 + RCSERVO_USECHANNEL5 + RCSERVO_USECHANNEL6 + RCSERVO_USECHANNEL7 + RCSERVO_USECHANNEL8 + RCSERVO_USECHANNEL9 + RCSERVO_USECHANNEL10 + RCSERVO_USECHANNEL11 + RCSERVO_USECHANNEL12 + RCSERVO_USECHANNEL13 + RCSERVO_USECHANNEL14 + RCSERVO_USECHANNEL15;


   roboio_SetRBVer(110);
    // Initialize PWM interface
   
    if (rcservo_Initialize(usedchannel) == false)
    {
        printf("ERR: fail to initialize RCSERVO (%s)!\n", roboio_GetErrMsg());

      
        return 1;
    }
   
    rcservo_EnterPWMMode();

    rcservo_SendPWMPulses(channel, period, duty, count);

    printf("Start to send %ld PWM pluses with period %ld us\n"
           "and duty %ld us on PWM channel %d.\n\n", count, period, duty, channel);

    while(rcservo_IsPWMCompleted(channel) == false);

    printf("Send %ld PWM pulses completed.\n", count);
    rcservo_Close();
   
   
    return 0;
}


However, I get the error message "I/O library fails to initialize!"

I have tried running the program as administrator, and that did not help.

Thanks in advance for your help.
Hello,
I am trying to run a simple PWM program on windows xp:

Code: Select all

#include "stdafx.h"
#include "iostream"
#include "roboard_dll.h"

#include <stdio>
#include <string>
#include <stdlib>

using namespace System;
using namespace std;

int main(array<System> ^args)
{
      
    int channel = 0;
   unsigned long usedchannel;
    unsigned long period  = 20000;
    unsigned long duty    = 1000;
    unsigned long count   = 300;

   usedchannel = RCSERVO_USECHANNEL0 + RCSERVO_USECHANNEL1 + RCSERVO_USECHANNEL2 + RCSERVO_USECHANNEL3 + RCSERVO_USECHANNEL4 + RCSERVO_USECHANNEL5 + RCSERVO_USECHANNEL6 + RCSERVO_USECHANNEL7 + RCSERVO_USECHANNEL8 + RCSERVO_USECHANNEL9 + RCSERVO_USECHANNEL10 + RCSERVO_USECHANNEL11 + RCSERVO_USECHANNEL12 + RCSERVO_USECHANNEL13 + RCSERVO_USECHANNEL14 + RCSERVO_USECHANNEL15;


   roboio_SetRBVer(110);
    // Initialize PWM interface
   
    if (rcservo_Initialize(usedchannel) == false)
    {
        printf("ERR: fail to initialize RCSERVO (%s)!\n", roboio_GetErrMsg());

      
        return 1;
    }
   
    rcservo_EnterPWMMode();

    rcservo_SendPWMPulses(channel, period, duty, count);

    printf("Start to send %ld PWM pluses with period %ld us\n"
           "and duty %ld us on PWM channel %d.\n\n", count, period, duty, channel);

    while(rcservo_IsPWMCompleted(channel) == false);

    printf("Send %ld PWM pulses completed.\n", count);
    rcservo_Close();
   
   
    return 0;
}


However, I get the error message "I/O library fails to initialize!"

I have tried running the program as administrator, and that did not help.

Thanks in advance for your help.
snest offline
Robot Builder
Robot Builder
Posts: 20
Joined: Thu Jul 22, 2010 10:00 pm

Re: I/O library fails to initialize (windows xp)

Post by roboard » Tue Oct 12, 2010 6:12 am

Post by roboard
Tue Oct 12, 2010 6:12 am

snest wrote:However, I get the error message "I/O library fails to initialize!"


Please put Winio.sys and Winio.dll in the same directory and try it again. :)
snest wrote:However, I get the error message "I/O library fails to initialize!"


Please put Winio.sys and Winio.dll in the same directory and try it again. :)
roboard offline
Savvy Roboteer
Savvy Roboteer
Posts: 302
Joined: Fri Jul 03, 2009 4:44 am

Post by snest » Tue Oct 12, 2010 8:09 pm

Post by snest
Tue Oct 12, 2010 8:09 pm

Thank You! This did the trick.

What is the purpose of WinIO.dll and WinIO.sys? Are those there to help the executable access the RoBoIO.dll file?

Also, are RoBoIO.dll, WinIO.dll and WinIO.sys the only files I need to include with my executable to get full functionality of the RoBoIO library?

Excuse the beginner questions, this is a learning project :).

Thanks again.
Thank You! This did the trick.

What is the purpose of WinIO.dll and WinIO.sys? Are those there to help the executable access the RoBoIO.dll file?

Also, are RoBoIO.dll, WinIO.dll and WinIO.sys the only files I need to include with my executable to get full functionality of the RoBoIO library?

Excuse the beginner questions, this is a learning project :).

Thanks again.
snest offline
Robot Builder
Robot Builder
Posts: 20
Joined: Thu Jul 22, 2010 10:00 pm

Post by roboard » Wed Oct 13, 2010 8:11 am

Post by roboard
Wed Oct 13, 2010 8:11 am

snest wrote:What is the purpose of WinIO.dll and WinIO.sys? Are those there to help the executable access the RoBoIO.dll file?

Also, are RoBoIO.dll, WinIO.dll and WinIO.sys the only files I need to include with my executable to get full functionality of the RoBoIO library?


RoBoIO employs WinIO to access I/O ports under WinXP. You need to put RoBoIO.dll, WinIO.dll, and WinIO.sys in the same directory, as well as install VC2005/VC2008 SP1 runtime redistributable package, for executing WinXP RoBoIO application.

:)
snest wrote:What is the purpose of WinIO.dll and WinIO.sys? Are those there to help the executable access the RoBoIO.dll file?

Also, are RoBoIO.dll, WinIO.dll and WinIO.sys the only files I need to include with my executable to get full functionality of the RoBoIO library?


RoBoIO employs WinIO to access I/O ports under WinXP. You need to put RoBoIO.dll, WinIO.dll, and WinIO.sys in the same directory, as well as install VC2005/VC2008 SP1 runtime redistributable package, for executing WinXP RoBoIO application.

:)
roboard offline
Savvy Roboteer
Savvy Roboteer
Posts: 302
Joined: Fri Jul 03, 2009 4:44 am


4 postsPage 1 of 1
4 postsPage 1 of 1
cron