Robobuilder RQ-HUNO & Ubuntu

Korean company maker of Robot kits and servos designed for of articulated robots. Re-incarnation of Megarobotics.
1 postPage 1 of 1
1 postPage 1 of 1

Robobuilder RQ-HUNO & Ubuntu

Post by RNope » Sun Apr 21, 2013 1:45 pm

Post by RNope
Sun Apr 21, 2013 1:45 pm

HI !

On my quest to control a RQ over the web ,(& despite the fact i succedded with other languages under Windows) i'm actually trying node.js and serialport lib, under Ubuntu.

Unfortunatly the little fellow doesn't move at all

I see three options:
Coding is wrong or it doesn't reach the robot because of a serial port adressing pb or both (or even something else ?)

My code , as javascript doesn't really stand byte array uses node.js buffers , looking at the manual http://nodejs.org/api/buffer.html
Code: Select all
var headerbuffer = new Buffer([0xFF, 0xFF, 0xAA, 0x55, 0xAA, 0x55, 0x37, 0xBA]);

seems pretty good to replace the C# command
Code: Select all
byte[] header = new byte[] { 0xFF, 0xFF, 0xAA, 0x55, 0xAA, 0x55, 0x37, 0xBA };

to create byte array
But i may be wrong on that point (even if helpers from no.js forum seems to say the same) especially on the exact nature of the buffer



On the other hand i suspect the data not to be sent or beeing sent at the wrong place

I did nothing special to install the USB to UART or robobuilder drivers yet.
It did not appeared to be a necessy to me (but i might be wrong) because:
$lsusb seems to see the device : 10c4:ea60 -> cp210x
$lsmod |grep cp 210x seems to confirm conrresponding driver is loaded
$ls -l /dev/ttyUSB0 confirm device was created

Despite that , i get a curious dmesg error :https://gist.github.com/anonymous/bf29d61c752e4363e585

Also ,something curious i noticed : Under Windows, the usb key lights the LED a few second a statup and then shut it down( and restart at data transmission) .
In Ubuntu , the red light is always on from the moment i plug it .

Has anyone some experience using a robobuilder with linux ? I couldn't find any searching over the web.

Thx a lot to any helper !
HI !

On my quest to control a RQ over the web ,(& despite the fact i succedded with other languages under Windows) i'm actually trying node.js and serialport lib, under Ubuntu.

Unfortunatly the little fellow doesn't move at all

I see three options:
Coding is wrong or it doesn't reach the robot because of a serial port adressing pb or both (or even something else ?)

My code , as javascript doesn't really stand byte array uses node.js buffers , looking at the manual http://nodejs.org/api/buffer.html
Code: Select all
var headerbuffer = new Buffer([0xFF, 0xFF, 0xAA, 0x55, 0xAA, 0x55, 0x37, 0xBA]);

seems pretty good to replace the C# command
Code: Select all
byte[] header = new byte[] { 0xFF, 0xFF, 0xAA, 0x55, 0xAA, 0x55, 0x37, 0xBA };

to create byte array
But i may be wrong on that point (even if helpers from no.js forum seems to say the same) especially on the exact nature of the buffer



On the other hand i suspect the data not to be sent or beeing sent at the wrong place

I did nothing special to install the USB to UART or robobuilder drivers yet.
It did not appeared to be a necessy to me (but i might be wrong) because:
$lsusb seems to see the device : 10c4:ea60 -> cp210x
$lsmod |grep cp 210x seems to confirm conrresponding driver is loaded
$ls -l /dev/ttyUSB0 confirm device was created

Despite that , i get a curious dmesg error :https://gist.github.com/anonymous/bf29d61c752e4363e585

Also ,something curious i noticed : Under Windows, the usb key lights the LED a few second a statup and then shut it down( and restart at data transmission) .
In Ubuntu , the red light is always on from the moment i plug it .

Has anyone some experience using a robobuilder with linux ? I couldn't find any searching over the web.

Thx a lot to any helper !
RNope offline
Newbie
Newbie
Posts: 5
Joined: Sun Jan 20, 2013 7:16 pm

1 postPage 1 of 1
1 postPage 1 of 1