SOLVED: HELP:RBC firmaware upgrade problem

Korean company maker of Robot kits and servos designed for of articulated robots. Re-incarnation of Megarobotics.
5 postsPage 1 of 1
5 postsPage 1 of 1

SOLVED: HELP:RBC firmaware upgrade problem

Post by jayden118 » Sat Jan 14, 2012 6:20 am

Post by jayden118
Sat Jan 14, 2012 6:20 am

Hi all,

I just bought a robobuilder and I have follow the c-programming instruction to download the firmware to the controller box.After i connected robobuilder to my laptop and run the RBC firmware upgrade tool, the error message like "bootloader is not response" pop up and i couldn't download the firmware to controller box.

Any hints can help me how to solve this problem??Hope you guys can help me out.Thanks.
Hi all,

I just bought a robobuilder and I have follow the c-programming instruction to download the firmware to the controller box.After i connected robobuilder to my laptop and run the RBC firmware upgrade tool, the error message like "bootloader is not response" pop up and i couldn't download the firmware to controller box.

Any hints can help me how to solve this problem??Hope you guys can help me out.Thanks.
jayden118 offline
Newbie
Newbie
Posts: 5
Joined: Sat Jan 14, 2012 6:12 am

Post by l3v3rz » Sat Jan 14, 2012 1:44 pm

Post by l3v3rz
Sat Jan 14, 2012 1:44 pm

Sounds like a communication problem - check your serial leads connected. I have by RBC off = start the download and then turn the RBC on. Also make sure no other program has grabbed the serial port - although I think if that's the case it says can't connect rather than no response.

The firmware download is a simple serial protocol that wait to see a ^ and then send a string wait for a response character and send another string etc until end of file.
Sounds like a communication problem - check your serial leads connected. I have by RBC off = start the download and then turn the RBC on. Also make sure no other program has grabbed the serial port - although I think if that's the case it says can't connect rather than no response.

The firmware download is a simple serial protocol that wait to see a ^ and then send a string wait for a response character and send another string etc until end of file.
l3v3rz offline
Savvy Roboteer
Savvy Roboteer
Posts: 473
Joined: Fri Jul 18, 2008 2:34 pm

Post by jayden118 » Sun Jan 15, 2012 8:42 am

Post by jayden118
Sun Jan 15, 2012 8:42 am

l3v3rz wrote:Sounds like a communication problem - check your serial leads connected. I have by RBC off = start the download and then turn the RBC on. Also make sure no other program has grabbed the serial port - although I think if that's the case it says can't connect rather than no response.

The firmware download is a simple serial protocol that wait to see a ^ and then send a string wait for a response character and send another string etc until end of file.


Thanks for your reply..my problem has been solved.Thank you so much..
l3v3rz wrote:Sounds like a communication problem - check your serial leads connected. I have by RBC off = start the download and then turn the RBC on. Also make sure no other program has grabbed the serial port - although I think if that's the case it says can't connect rather than no response.

The firmware download is a simple serial protocol that wait to see a ^ and then send a string wait for a response character and send another string etc until end of file.


Thanks for your reply..my problem has been solved.Thank you so much..
jayden118 offline
Newbie
Newbie
Posts: 5
Joined: Sat Jan 14, 2012 6:12 am

Post by forma » Thu Jul 12, 2012 8:56 am

Post by forma
Thu Jul 12, 2012 8:56 am

Can you please tell us how did you solve the problem? Or did it resolved by itself? Thnx
Can you please tell us how did you solve the problem? Or did it resolved by itself? Thnx
forma offline
Newbie
Newbie
Posts: 2
Joined: Thu Jul 12, 2012 8:46 am

Post by PedroR » Thu Jul 12, 2012 10:12 am

Post by PedroR
Thu Jul 12, 2012 10:12 am

Hi

I believe the user solved the problem by following the advice of l3v3rz (see post above).

You cana lso test to see if MotionBuilder works OK.
If it works OK then it's not a serial communication issue.

You're probably forgetting to press the reset pin or power cycle when asked.

Regards.
Pedro
Hi

I believe the user solved the problem by following the advice of l3v3rz (see post above).

You cana lso test to see if MotionBuilder works OK.
If it works OK then it's not a serial communication issue.

You're probably forgetting to press the reset pin or power cycle when asked.

Regards.
Pedro
PedroR offline
Savvy Roboteer
Savvy Roboteer
Posts: 1199
Joined: Mon Jun 16, 2008 11:07 pm


5 postsPage 1 of 1
5 postsPage 1 of 1
cron