Problem with assembler file

Korean company maker of Robot kits and servos designed for of articulated robots. Re-incarnation of Megarobotics.
2 postsPage 1 of 1
2 postsPage 1 of 1

Problem with assembler file

Post by koli » Mon May 31, 2010 10:24 am

Post by koli
Mon May 31, 2010 10:24 am

Hello

Once I have the file *.asm have to compile it with the program
"Wavrasm".
Well, the file gives me several mistakes, someone can help me?

The mistakes are the following ones:

syntax error
#pragma AVRPART ADMIN PART_NAME ATmega128
syntax error
#pragma AVRPART MEMORY PROG_FLASH 131072
syntax error
#pragma AVRPART MEMORY EEPROM 4096
syntax error
#pragma AVRPART MEMORY INT_SRAM SIZE 4096
syntax error
#pragma AVRPART MEMORY INT_SRAM START_ADDR 0x100
syntax error
#ifndef __SLEEP_DEFINED__
syntax error
#define __SLEEP_DEFINED__
syntax error
#endif
symbol is already defined by the .EQU directive
.EQU __se_bit=0x20
symbol is already defined by the .EQU directive
.EQU __sm_mask=0x1C
symbol is already defined by the .EQU directive
.EQU __sm_powerdown=0x10
symbol is already defined by the .EQU directive
.EQU __sm_powersave=0x18
symbol is already defined by the .EQU directive
.EQU __sm_standby=0x14
symbol is already defined by the .EQU directive
.EQU __sm_ext_standby=0x1C
symbol is already defined by the .EQU directive
.EQU __sm_adc_noise_red=0x08


these are the mistakes
please i need help
Hello

Once I have the file *.asm have to compile it with the program
"Wavrasm".
Well, the file gives me several mistakes, someone can help me?

The mistakes are the following ones:

syntax error
#pragma AVRPART ADMIN PART_NAME ATmega128
syntax error
#pragma AVRPART MEMORY PROG_FLASH 131072
syntax error
#pragma AVRPART MEMORY EEPROM 4096
syntax error
#pragma AVRPART MEMORY INT_SRAM SIZE 4096
syntax error
#pragma AVRPART MEMORY INT_SRAM START_ADDR 0x100
syntax error
#ifndef __SLEEP_DEFINED__
syntax error
#define __SLEEP_DEFINED__
syntax error
#endif
symbol is already defined by the .EQU directive
.EQU __se_bit=0x20
symbol is already defined by the .EQU directive
.EQU __sm_mask=0x1C
symbol is already defined by the .EQU directive
.EQU __sm_powerdown=0x10
symbol is already defined by the .EQU directive
.EQU __sm_powersave=0x18
symbol is already defined by the .EQU directive
.EQU __sm_standby=0x14
symbol is already defined by the .EQU directive
.EQU __sm_ext_standby=0x1C
symbol is already defined by the .EQU directive
.EQU __sm_adc_noise_red=0x08


these are the mistakes
please i need help
koli offline
Robot Builder
Robot Builder
Posts: 7
Joined: Mon Apr 12, 2010 4:34 pm

Post by badcommandorfilename » Fri Jul 09, 2010 4:39 am

Post by badcommandorfilename
Fri Jul 09, 2010 4:39 am

I've never heard of Wavrasm, but I think the first part of your problem is due to the fact that the compiler doesn't understand the pragmas you have used. Pragmas are instructions to the compiler to tell it how to behave, but usually need to be directed to a specific program. Wavrasm probably has it's own pragma syntax, so you will need to translate the commands.

Or, just switch to codevision or avr-gcc to compile your code.


-------
http://buildtherobot.blogspot.com/ - for robot builders and enthusiasts.
I've never heard of Wavrasm, but I think the first part of your problem is due to the fact that the compiler doesn't understand the pragmas you have used. Pragmas are instructions to the compiler to tell it how to behave, but usually need to be directed to a specific program. Wavrasm probably has it's own pragma syntax, so you will need to translate the commands.

Or, just switch to codevision or avr-gcc to compile your code.


-------
http://buildtherobot.blogspot.com/ - for robot builders and enthusiasts.
badcommandorfilename offline
Robot Builder
Robot Builder
Posts: 12
Joined: Fri Dec 11, 2009 11:34 am


2 postsPage 1 of 1
2 postsPage 1 of 1
cron